ibm_db2 2.1.0

Extension for IBM DB2 Universal Database, IBM Cloudscape, and Apache Derby


This extension supports IBM DB2 Universal Database, IBM
Cloudscape, and Apache Derby databases.

License: Apache License 2.0

Changes

* 2020-11-30: 2.1.0
- Compatibility with PHP 8
- Fix compatibility with 64-bit PASE/modern IBM i (sqlcli-dev package, pointer/integer width mismatch, XMLSERVICE location, etc)
- Backport character trim from Zend Server
- Major improvements to test suite (fix broken tests, less hardcoding)
- Handle CCSID 65535 on IBM i
- Fix warnings (returning void from non-void, etc)